Print Page | Close Window

MSRToolkit won't open

Printed From: MSSpeech-Forum
Category: Windows™ Speech Recognition Forums
Forum Name: WSRToolkit
Forum Description: Questions and Answers for using the WSRToolkit features
Printed Date: 05/Dec/2020 at 4:57am
Software Version: Web Wiz Forums 12.02 -

Topic: MSRToolkit won't open
Posted By: sebb
Subject: MSRToolkit won't open
Date Posted: 20/Feb/2015 at 12:34pm

I purchased two days ago both the WSRToolkit and the WSRMacro User Guide.
After several attempts at installation, and re-installation following all procedures as described in the installation guide, I still have the same error:


I have not been able to get the software to start at all. It crashes on start-up.

Any ideas?

Thank You.

Posted By: mmarkoe_admin
Date Posted: 20/Feb/2015 at 5:41pm
We've not heard of this error message before. A Google search for CLR20r3 shows it is a common error message related to Windows with several solutions offered.

My suggestions:
1. Check Control Panel - Programs and Features to see if Windows Speech Toolkit shows. If it is there, uninstall.
2. If you have not already done so, install all Microsoft system updates and reboot computer.
3. In case there was a problem with the download, re-download WSRToolkit at:
Re-download the WSRToolkit from:
4. Temporarily disable Anti-Virus and try installing WSRToolkit.

If the above does not work and no one else offers suggestions, I'll contact our programmer.


Posted By: sebb
Date Posted: 21/Feb/2015 at 7:48am
Hello Marty,

Thank you for your response.

However, the problem is not solved after following your advice (uninstall-update+reboot-download new copy-disable AV-install). I get the same error message I posted earlier.

My coding is really rusty but I believe the error CLR20r3 in this case, refers to the throw (IL_001c) of System.InvalidOperationException from the method 060063E0, which is part of the .class "(…) System.Security.Cryptography(…) in mscorlib, when called upon by WSRToolkit.exe v

But I could be wrong, I usually am.

Hope this will help you solve the problem,

Yours truly,


BTW: I really enjoyed the WSRMacro guide, well worth a reading for anyone. Thumbs-up!

Posted By: mmarkoe_admin
Date Posted: 21/Feb/2015 at 8:12am
You may want to try a Registry cleaner first as the error message search shows indications of a problem with the Registry. I've been using - CCleaner Registry and IE cleaner for 8 years with great results and no problems. The link is to CNET's site which is highly reliable. Make sure to reboot after cleaning registry.

Please provide detail on which version of Windows you are using? Did you do a google search and see any other issues that may apply like the .NET Framework? Uninstall older an version of .NET and install or reinstall newest version.

If you have another computer available you should try installing on this. A successful installation will indicate there is something on your main computer interfering.

Our programmer is receiving a link to this thread and will either respond to me or respond here.


Posted By: antihadron
Date Posted: 23/Feb/2015 at 6:53am
Hello Sebb (and Marty)

Can you provide some details on your operating system,  
1) What is the Windows version you are using? (and is it 64 or 32 bit os)
2) What version of .NET you have installed?  In case you do not know, here are some instructions on how to determine that.

I did a preliminary search and this seems to indicate that there are missing windows components that are usually present.  This problem relates to a different issue with the windows media player, but it might be a clue to the actual problem.

Have you previously removed windows components from this machine?  I'm not sure what component would cause the error but its a possibility.

Finally, can you confirm that you are able to 

1) Start Windows Speech Recognition and do some speech recognition (e.g. in notepad) without running the toolkit
2) Confirm that you are able to run the Microsoft Macros Program.

Hopefully one or more of these tests will show what needs to be changed on your machine to get past this error,  I suspect there is some dependency/library that is missing that is usually present on a  'clean' machine, but has been removed or modified on yours.

Best Regards,


Posted By: sebb
Date Posted: 23/Feb/2015 at 8:33am
Hello Nathaniel,

Thank you for your response.

I am going to try your solution tonight when i get home.

In the meantime, i got what you asked for, i hope, which is these screenshoots from my computer.

This is a set of 5 pictures in png format.

Hope it helps,


Posted By: mmarkoe_admin
Date Posted: 23/Feb/2015 at 9:20am
Originally posted by sebb sebb wrote:

Hello Nathaniel,
Thank you for your response.

It appears the text macro for Hello Nathaniel executed properly. Just a suggestion, name your macros something unique in order to differentiate from common words in the WSR vocabulary. This will avoid the common word from being recognized instead of execution of the macro. In this vein, it also helps to give a slight pause when issuing any command to avoid the command word(s) being recognized as text.

The suggestion was given to try installing WSRToolkit on another computer assuming the other computer has standard components. This will at least tell you if the WSRToolkit software is or is not the problem.

PS. Nathaniel is the programmer for WSRToolkit Versions 2 and 3.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.02 -
Copyright ©2001-2019 Web Wiz Ltd. -